Announcement

Collapse
No announcement yet.

Oven help?? pid help???

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Oven help?? pid help???

    Does anyone know what happn lol....

    I have a teds oven and everything was working fine till 2-3 days ago when my pid toook about 10min to light up and my oven then started to work...Well now when I turn the power on the only thing that works is the light,fan ....not the pid nor will it light up or will it heat up......


    Do you think the pid went out and thats why its not heating up???




    Also what pid does ted use and where to buy them asap??



    Thanks

  • #2
    right on the front is the name and model number take that to ebay and run a search should be plenty of them ,I think its Auber but what model I have no idea

    Comment


    • #3
      You can probably get ahold of Ted over on Powder365's forum (http://powder365.com/forum/index.php). Ted, duke, or ed1966ss should be able to help you figure it out.
      Dan
      sigpic

      I carry a gun because I'm too young to die, and too old to take an ass-whoopin'!

      Comment


      • #4
        Contact Reliant Ovens. Get professional advice.

        Comment


        • #5
          It's the cold. Warm the shop/garage and it will work. You could also hit it with a hair dryer for a few minutes. Its a known problem. Ted posted about this on another forum and it fixed it for me.

          Comment


          • #6
            Thanks

            Ted called and I'm going to try it tomorrow when I get over to the shop


            Thanks

            Comment


            • #7
              yes it cause its cold in the shop . I had the same problem last week, ordered a new one and it did it til the shop warmed up.. TED varified this on another forum.

              Comment


              • #8
                yea i got....thanks!

                Comment

                Working...
                X