Announcement

Collapse
No announcement yet.

Illusion Purple Issues

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Illusion Purple Issues

    Hey guys, new to the forum, been doing powdering for about 6 months now.

    Ok, this is probably the only illusion color (so far) that I have had issues with

    Using the Hyper Smooth 2.0 gun. KV setting around 70, 50 for 2nd coat, rod 8 feet into the ground.

    I keep getting random silvery/metallic patches in my finish for this color. It is never consistent and I have to keep redoing it over and over.

    For the life of me I cannot get a consistent result, I have even spoken with Prismatic tech support about it and they are lost, as I have tried every combination of, light, medium, and heavy coats of both base and clear coat and I still am getting 'bunched up silver' spots randomly

    I am more than positive I have full coverage, I even went to the extreme on a sample to spray a lot to the point where it might run, and I would still get some spots.

    By some string of luck I would get a finished product that had full purple and no silver/metallic, but it would take multiple attempts and hours of my day.

    Prismatic is sending me another pound just to rule out possible bad batch, and asked for me to send them a sample finish so they can analysis. I might even make a video lol.

    This seems to happen only with purple, my violet seems to be consistent and the only time it shows silver on that is when I do the ombre effect and purple is sprayed over it

    I have a illusion blue as well, which I have not tried, but I fear it might be the same as purple
Working...
X